사용자 삽입 이미지
오라클 자바의 보안 취약점 논란이 지속되고 있습니다. 오라클 측이 지난 13 자바7 취약점 문제를 해소하기 위해 업데이트 11 선보였는데, 이것도 충분치 않다는 의견이 지배적입니다.

심지어 미국 국토안보부는 " 브라우저에서 반드시 자바를 써야 하는 경우가 아니라면 '사용하지 않음'으로 기본 설정을 바꾸라" 경고하며 "그것이 앞으로 발견될 수도 있는 자바 취약점으로 인한 문제를 경감시킬 "이라고 밝혔습니다.

국토안보부는 지난 10일에도 "오라클 자바7 업데이트 10 이전 버전들은 허가받지 않은 공격자들이  원격에서 시스템을 제멋데로 조정할 수 있는 취약점을 안고 있다"면서 "기존 자바 취약점들은 이미 광범위하게 해커들의 타겟이 됐고 새로운 자바 취약점도 나타날 것으로 본다"고 발표한바 있습니다.

자바는 보안 취약점이 많은 플랫폼입니다. 러시아의 보안회사 카스퍼스키에 따르면, 지난 해 발생한 사이버 공격의 절반이 자바 취약점을 이용한 것으로 조사됐습니다.

그러나 자바는 전 세계에서 가장 인기 있는 프로그래밍 플랫폼입니다. 30억 개의 디바이스에서 자바가 구동되고 있는 것으로 알려져 있습니다.

그러나 보안취약점 문제가 개선되지 않고 지속된다면 자바 플랫폼의 미래는 어두울 것입니다. 이미 파이어폭스 등은 자바가 실행되지 않도록 하는 옵션을 기본으로 변경했습니다. 사용자가 자바를 실행하겠다고 클릭을 해야만 자바가 실행되는 것입니다.

오라클 측은 적절한 대책을 마련할 것을 기대합니다.

<심재석 기자>sjs@ddaily.co.kr

2013/01/15 10:06 2013/01/15 10:06

트랙백 주소 :: 이 글에는 트랙백을 보낼 수 없습니다